WrenSoft Zoom Search Engine 2.0 Build: 1018 Cross-Site Scripting Vulnerability



EDB-ID: 23244 CVE: 2003-1498 OSVDB-ID: 2669
Author: Ezhilan Published: 2003-10-14 Verified: Verified
Exploit Code:   Download Vulnerable App:   N/A

Rating

(0.0)
Prev Home Next
source: http://www.securityfocus.com/bid/8823/info

WrenSoft Zoom Search Engine is prone to a cross-site scripting issue in the software's search module. A remote attacker may be able to execute HTML or script code in a user's browser.

The problem occurs because the software fails to properly sanitize user-supplied input. An attacker may be able to a construct a malicious link containing HTML or script code that may be rendered in a user's browser upon visiting that link. This attack would occur in the security context of the vulnerable site.

http://www.example.com/search.php?zoom_query=<script>alert("hello")</script><script>alert("hello")</script>