network tracker .95 - Persistent Cross-Site Scripting

EDB-ID:

17694

CVE:

N/A


Author:

G13

Type:

webapps


Platform:

PHP

Date:

2011-08-19


Become a Certified Penetration Tester

Enroll in Penetration Testing with Kali Linux and pass the exam to become an Offensive Security Certified Professional (OSCP). All new content for 2020.

GET CERTIFIED

# Exploit Title: Network Tracker .95 Stored XSS
# Date: 08-18-2011
# Author: G13
# Software link: http://networktracker.org/
# Version: .95

ISSUE

The application contains a option which allows anyone to create a user. 
If this option is left enabled an attacker could launch a stored XSS 
attack against the vulnerable application

Vulnerability:

Network Tracker does not escape the data entry on the Description and 
Brand fields of a device.  An attacker may enter 
<script>alert(100);</script> into these fields to cause the exploit.