FlexCMS 3.2.1 - Persistent Cross-Site Scripting

EDB-ID:

18608

CVE:



Author:

storm

Type:

webapps


Platform:

PHP

Date:

2012-03-16


Become a Certified Penetration Tester

Enroll in Penetration Testing with Kali Linux and pass the exam to become an Offensive Security Certified Professional (OSCP). All new content for 2020.

GET CERTIFIED

#Persistent XSS in FLEXCMS 3.2.1
#Software vendor: http://www.flexcms.com/flex/index.html

The Persistent XSS appears when any user 
go to >> edit profile >> Display name >> and then injects the xss code instead of his display name. 

After inkection this code. In the main page of the webiste, there is "Users Online" menu. 

This menu is  by default in every page of the website. Therefore, all useres will be affected of this vulnerabiltym, and they can be redirected, or thier session could be hijacked