Wireshark - Misaligned Memory Denial of Service

EDB-ID:

18920




Platform:

Multiple

Date:

2012-05-24


Become a Certified Penetration Tester

Enroll in Penetration Testing with Kali Linux , the course required to become an Offensive Security Certified Professional (OSCP)

GET CERTIFIED

source: https://www.securityfocus.com/bid/53653/info

Wireshark is prone to a denial-of-service vulnerability. 

An attacker can exploit this issue to crash the affected application, denying service to legitimate users. 

Wireshark versions 1.6.0 through 1.6.7 and versions 1.4.0 through 1.4.12 are vulnerable.

PoC:
https://github.com/offensive-security/exploitdb-bin-sploits/raw/master/bin-sploits/18920.pcap