BBC Education Betsie 1.5 - Parserl.pl Cross-Site Scripting

EDB-ID:

21587




Platform:

CGI

Date:

2002-07-01


Become a Certified Penetration Tester

Enroll in Advanced Web Attacks and Exploitation , the course required to become an Offensive Security Web Expert (OSWE)

GET CERTIFIED

source: https://www.securityfocus.com/bid/5135/info

Betsie (BBC Education Text to Speech Internet Enhancer) is prone to a cross-site scripting vulnerability. This issue exists in the parserl.pl script.

Attackers may exploit this condition via a malicious link to a site running the vulnerable software. Successful exploitation will enable an attacker to cause script code to be executed in the web browser of a user who visits the malicious link. 

http://server/cgi-bin/betsie/parserl.pl/<script>alert("eek!")</script>