achievo 1.4.5 - Multiple Vulnerabilities

EDB-ID: 22431 CVE: N/A OSVDB-ID: 75065...
Verified: Author: Canberk BOLAT Published: 2012-11-02
Download Exploit: Source Raw Download Vulnerable App:
Name :  XSS, LFI and SQL Injection Vulnerabilities in Achievo
Software :  Achievo 1.4.5 and possibly below.
Vendor Homepage :
Vulnerability Type :  Cross-Site Scripting, Local File Inclusion and SQL
Severity :  Critical
Researcher :  Canberk Bolat
Advisory Reference :  NS-12-016

Achievo is a flexible web-based resource management tool for business
environments. Achievo's resource management capabilities will enable
organisations to support their business processes in a simple, but
effective manner.

Achievo is affected by XSS, LFI and SQL Injection vulnerabilities in
version 1.4.5.
XSS: (GET: atklevel, atkaction, atkstackid,
atkselector, atkfilter, searchString)
SQL Injection:
You can read the full article about Cross-Site Scripting, LFI and SQL
Injection vulnerabilities from here:

Cross-site Scripting (XSS):
Local File Inclusion:
Blind SQL Injection:


Advisory Timeline
23/01/2011 - First contact
25/02/2012 - Second contact - No response
01/11/2012 - Advisory released

It has been discovered on testing of Netsparker, Web Application Security
Scanner -

Vendor Url / Patch : -
MSL Advisory Link :
Netsparker Advisories :

About Netsparker
NetsparkerĀ® can find and report security issues such as SQL Injection and
Cross-site Scripting (XSS) in all web applications regardless of the
platform and the technology they are built on. Netsparker's unique
detection and exploitation techniques allows it to be dead accurate in
reporting hence it's the first and the only False Positive Free web
application security scanner.

Netsparker Advisories, <>