Mod_NTLM 0.x - Authorisation Heap Overflow

EDB-ID:

22512

CVE:





Platform:

Multiple

Date:

2003-04-21


Become a Certified Penetration Tester

Enroll in Penetration Testing with Kali Linux , the course required to become an Offensive Security Certified Professional (OSCP)

GET CERTIFIED

source: https://www.securityfocus.com/bid/7388/info

The mod_ntlm Apache module has been reported prone to a heap overflow vulnerability.

The vulnerability occurs due to a lack of sufficient bounds checking performed on user-supplied data, stored in heap memory. By supplying excessive data an attacker may trigger a buffer overflow and corrupt crucial memory management structures. This may result in the execution of arbitrary code in the context of the Apache server.

This vulnerability is reported to affect mod_ntlm <= v0.4 for Apache 1.3 and mod_ntlmv2 version 0.1 for Apache 2.0. 

GET / HTTP/1.0
Authorization: [Ax3000]