PHPGedView 2.x - 'Editconfig_gedcom.php' Directory Traversal

EDB-ID:

23616

CVE:

N/A


Platform:

PHP

Published:

2004-01-30

source: https://www.securityfocus.com/bid/9529/info

It has been reported that PhpGedView may be prone to a directory traversal vulnerability that may allow a remote attacker to access files outside the server root directory. The problem exists due to insufficient sanitization of user-supplied data via the 'gedcom_config' parameter of the 'editconfig_gedcom.php' script.

PhpGedView versions 2.65.1 and prior have been reported to be prone to this issue.

http://www.example.com/[phpGedView-directory]/editconfig_gedcom.php?gedcom_config=../../../../../../etc/passwd