eCommerce Corporation Online Store Kit 3.0 - 'More.php' Cross-Site Scripting

EDB-ID:

23712


Platform:

PHP

Published:

2003-02-17

source: http://www.securityfocus.com/bid/9676/info
 
Multiple vulnerabilities have been identified in the software due to improper sanitization of user-supplied input. Successful exploitation of these issues could allow an attacker to carry out cross-site scripting and SQL injection attacks via the 'id' parameter of 'more.php' script.
 
Online Store Kit version 3.0 has been reported to be prone to these issues.

more.php?id=%3Cscript%3Ealert(document.domain);%3C/script%3E&