Mozilla Browser 1.7.x - Non-ASCII Hostname Heap Overflow

EDB-ID:

24597

CVE:

N/A




Platform:

Multiple

Date:

2004-09-14


Become a Certified Penetration Tester

Enroll in Penetration Testing with Kali Linux , the course required to become an Offensive Security Certified Professional (OSCP)

GET CERTIFIED

source: https://www.securityfocus.com/bid/11169/info

Mozilla is prone to a remotely exploitable heap overflow that is exposed when the browser handles non-ASCII characters in URIs. 

This issue could be exploited by enticing a user to open a hyperlink that references a malicious URI. Successful exploitation will allow execution of arbitrary code in the context of the client user.

http://é------------------------------------------------aaaabbbb-----/

http://é------------------------------------------------þßý-----/

http://é------------------------------------------------aaaa$ðý-----/