O-Kiraku Nikki 1.3 - 'Nikki.php' SQL Injection

EDB-ID:

26683


Author:

r0t

Type:

webapps


Platform:

PHP

Date:

2005-11-30


Become a Certified Penetration Tester

Enroll in Advanced Web Attacks and Exploitation , the course required to become an Offensive Security Web Expert (OSWE)

GET CERTIFIED

source: https://www.securityfocus.com/bid/15657/info

O-Kiraku Nikki is prone to an SQL injection vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input before using it in an SQL query.

Successful exploitation could result in a compromise of the application, disclosure or modification of data, or may permit an attacker to exploit vulnerabilities in the underlying database implementation.

Versions 1.3 and prior are reported to be vulnerable; other versions may also be affected. 

http:///okiraku.php?lang=&day_id=[SQL]