TinyPHPForum 3.6 - Multiple Directory Traversal Vulnerabilities

EDB-ID:

27038




Platform:

PHP

Date:

2006-01-06


Become a Certified Penetration Tester

Enroll in Advanced Web Attacks and Exploitation , the course required to become an Offensive Security Web Expert (OSWE)

GET CERTIFIED

source: https://www.securityfocus.com/bid/16163/info

TinyPHPForum is prone to multiple directory traversal vulnerabilities. These issues are due to a failure in the application to properly sanitize user-supplied input.

An attacker can exploit these vulnerabilities to retrieve arbitrary files from the vulnerable system in the context of the Web server process. Information obtained may aid in further attacks; other attacks are also possible.

These issues are reported to affect version 3.6; earlier versions may also be vulnerable. 

http://www.example.com/tpf/profile.php?action=view&uname=../../username