WordPress 2.0 - Comment Post HTML Injection

EDB-ID:

27227

Author:

imei

Type:

webapps

Platform:

PHP

Published:

2006-02-15

source: http://www.securityfocus.com/bid/16656/info

WordPress is prone to an HTML-injection vulnerability. 

Attacker-supplied HTML and script code would be executed in the context of the affected website, potentially allowing for the theft of cookie-based authentication credentials. An attacker could also exploit this issue to control how the site is rendered to the user; other attacks are also possible.

WordPress version 2.0.0 is reportedly vulnerable; other versions may also be affected.

An example has been provided:

<strong>author's website</strong>:
<strong>" onfocus="alert(1)" onblur="alert(1)</strong>