Joomla! Component VirtueMart Joomla! eCommerce Edition 1.0.11 - Multiple Input Validation Vulnerabilities

EDB-ID:

28719




Platform:

PHP

Date:

2006-09-27


Become a Certified Penetration Tester

Enroll in Advanced Web Attacks and Exploitation , the course required to become an Offensive Security Web Expert (OSWE)

GET CERTIFIED

source: https://www.securityfocus.com/bid/20236/info

VirtueMart Joomla eCommerce Edition is prone to multiple input-validation vulnerabilities because the application fails to properly sanitize user-supplied input.

An attacker can exploit these issues to execute arbitrary HTML and script code in the browser of a victim user in the context of the affected website. This may allow the attacker to steal cookie-based authentication credentials, to control how the site is rendered to the user, and to launch other attacks.

VirtueMart Joomla eCommerce Edition version 1.0.11 is vulnerable; earlier versions may also be vulnerable.

GET: http://www.example.com/index.php
option=com_contact&Itemid="><script>alert('XSS');</script>
POST: http://www.example.com/index.php
subscriber_name=1&email=1&task=subscribe&Itemid="><script>alert('XSS');</script>