KDPics 1.11/1.16 - 'galeries.inc.php3?categories' Cross-Site Scripting

EDB-ID:

29255


Platform:

PHP

Published:

2006-12-09

source: http://www.securityfocus.com/bid/21515/info
 
KDPics is prone to multiple input-validation vulnerabilities, including cross-site scripting and remote file-include issues, because the application fails to sanitize user-supplied input.
 
A successful exploit may allow unauthorized users to view files, to execute arbitrary scripts within the context of the browser, and to steal cookie-based authentication credentials. Other attacks are also possible.
 
KDPics 1.16 and prior versions are vulnerable.

http://www.example.com/[kdpics_path]/galeries.inc.php3?categories=[XSS]