Indexu 5.0/5.3 - 'suggest_category.php?Error_msg' Cross-Site Scripting

EDB-ID:

29478


Platform:

PHP

Published:

2007-01-16

source: http://www.securityfocus.com/bid/22084/info
 
Indexu is prone to multiple cross-site scripting vulnerabilities because it fails to properly sanitize user-supplied input.
 
An attacker may leverage these issues to have arbitrary script code execute in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.
 
Indexu 5.3.0 and prior versions are vulnerable; other versions may also be affected. 

http://www.example.com/INDEXU_PATH/suggest_category.php?error_msg=[XSS]