Multiple Personal Firewall Products - Local Protection Mechanism Bypass

EDB-ID:

30039

CVE:

N/A




Platform:

Multiple

Date:

2007-05-15


Become a Certified Penetration Tester

Enroll in Penetration Testing with Kali Linux and pass the exam to become an Offensive Security Certified Professional (OSCP). All new content for 2020.

source: https://www.securityfocus.com/bid/23987/info

Multiple personal firewall products are prone to a vulnerability that lets attackers bypass protection mechanisms. This issue occurs because the applications fail to properly implement protection mechanisms based on valid process identifiers.

Exploiting this issue allows local attackers to bypass protection mechanisms implemented to restrict access to the memory space of critical processes. This allows attackers to execute arbitrary code with elevated privileges; other attacks are also possible.

The following applications are vulnerable to this issue:
- Comodo Firewall Pro 2.4.18.184
- Comodo Personal Firewall 2.3.6.81
- ZoneAlarm Pro 6.1.744.001

Other applications and versions may also be affected.

https://github.com/offensive-security/exploitdb-bin-sploits/raw/master/bin-sploits/30039-1.zip

https://github.com/offensive-security/exploitdb-bin-sploits/raw/master/bin-sploits/30039-2.zip