JSPWiki 2.5.139 - 'NewGroup.jsp' Multiple Cross-Site Scripting Vulnerabilities

EDB-ID:

30608


Platform:

JSP

Published:

2007-09-25

source: https://www.securityfocus.com/bid/25803/info

JSPWiki is prone to multiple input-validation vulnerabilities, including multiple cross-site scripting issues and an HTML-injection issue, because the application fails to adequately sanitize user-supplied input.

Attacker-supplied HTML and script code will run in the context of the affected site, potentially allowing the attacker to steal cookie-based authentication credentials or to control how the site is rendered to the user; other attacks are also possible.

Versions prior to JSPWiki 2.5.138-beta are vulnerable. 

http://www.example.com/wiki/NewGroup.jsp?group=[XSS]