Bitweaver 1.x/2.0 - 'search/index.php' Cross-Site Scripting

EDB-ID:

30879

Author:

Doz

Type:

webapps

Platform:

PHP

Published:

2007-11-10

source: http://www.securityfocus.com/bid/26801/info
 
Bitweaver is prone to multiple input-validation vulnerabilities because the application fails to sufficiently sanitize user-supplied input including multiple cross-site scripting vulnerabilities, multiple HTML-injection vulnerabilities, and an SQL-injection vulnerability.
 
A successful exploit of these vulnerabilities could allow an attacker to compromise the application, access or modify data, steal cookie-based authentication credentials, or exploit vulnerabilities in the underlying database. Other attacks are also possible.
 
Bitweaver 2.0.0 and prior versions are vulnerable to these issues.

http://www.example.com/search/index.php/XSS