xt:Commerce 3.04 - 'advanced_search_result.php?keywords' Cross-Site Scripting

EDB-ID:

32405


Platform:

PHP

Published:

2008-09-22

source: http://www.securityfocus.com/bid/31313/info

xt:Commerce is prone to multiple vulnerabilities, including a session-fixation vulnerability and a cross-site scripting vulnerability.

An attacker can leverage the session-fixation issue to hijack a session of an unsuspecting user. The attacker can exploit the cross-site scripting issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This can allow the attacker to steal cookie-based authentication credentials and to launch other attacks.

xt:Commerce 3.04 is vulnerable; other versions may also be affected.

https://www.example.com/advanced_search_result.php?keywords=/>"<script>alert(15)</script>&x=1&y=1