Z1Exchange 1.0 - 'id' Cross-Site Scripting

EDB-ID:

32634


Platform:

PHP

Published:

2008-12-02

source: https://www.securityfocus.com/bid/32598/info
 
Z1Exchange is prone to an SQL-injection vulnerability and a cross-site scripting vulnerability because it fails to sufficiently sanitize user-supplied data.
 
Exploiting these issues could allow an attacker to steal cookie-based authentication credentials, compromise the application, access or modify data, or exploit latent vulnerabilities in the underlying database.
 
Z1Exchange 1.0 is vulnerable; other versions may also be affected. 

http://www.example.com/[Path]/showads.php?id=<script>alert(1369)</script>