Adobe Flex SDK 3.x - 'index.template.html' Cross-Site Scripting

EDB-ID:

33180


Platform:

Multiple

Published:

2009-08-19

source: http://www.securityfocus.com/bid/36087/info

Adobe Flex SDK is prone to a cross-site scripting vulnerability because it fails to properly sanitize user-supplied input to express-install template files.

An attacker could exploit this vulnerability to execute arbitrary script code in the context of a web application built using the SDK. This may allow the attacker to steal cookie-based authentication credentials and to launch other attacks.

Versions prior to Flex SDK 3.4 are vulnerable. 

http://www.example.com/Flex/index.template.html?"/></object><script>alert('XSS')</script>