osCommerce 3.0a5 - Local File Inclusion / HTML Injection

EDB-ID:

33913

CVE:

N/A




Platform:

PHP

Date:

2010-04-30


Become a Certified Penetration Tester

Enroll in Advanced Web Attacks and Exploitation , the course required to become an Offensive Security Web Expert (OSWE)

GET CERTIFIED

source: https://www.securityfocus.com/bid/39820/info

osCommerce is prone to a local file-include vulnerability and an HTML-injection vulnerability because it fails to properly sanitize user-supplied input.

An attacker can exploit the local file-include vulnerability using directory-traversal strings to execute local files within the context of the webserver process.

The attacker may leverage the HTML-injection issue to execute arbitrary HTML and script code in the context of the affected browser. This may let the attacker steal cookie-based authentication credentials or control how the site is rendered to the user.

osCommerce 3.0a5 is affected; other versions may also be vulnerable. 

http://www.example.com/admin/includes/applications/services/pages/uninstall.php?module=../../../../../../../../cmd