Basic Analysis and Security Engine (BASE) 1.4.5 - 'base_ag_main.php' Crafted Arbitrary File Upload / Arbitrary Code Execution

EDB-ID:

36760




Platform:

PHP

Date:

2012-02-11


Become a Certified Penetration Tester

Enroll in Advanced Web Attacks and Exploitation , the course required to become an Offensive Security Web Expert (OSWE)

GET CERTIFIED

source: https://www.securityfocus.com/bid/51979/info
                                      
BASE is prone to a security-bypass vulnerability and multiple remote file-include vulnerabilities.
                                      
An attacker can exploit these issues to gain unauthorized access, obtain potentially sensitive information, or execute arbitrary script code in the context of the webserver process. This may allow the attacker to compromise the application and the computer; other attacks are also possible.
                                      
BASE 1.4.5 is vulnerable; other versions may be affected.

http://www.example.com/base_ag_main.php?ag_action=create File and past your code