Mesh Viewer 0.2.2 - Remote Buffer Overflow

EDB-ID:

25026

CVE:

N/A




Platform:

Windows

Date:

2004-12-15


Become a Certified Penetration Tester

Enroll in Penetration Testing with Kali Linux and pass the exam to become an Offensive Security Certified Professional (OSCP). All new content for 2020.

GET CERTIFIED

source: https://www.securityfocus.com/bid/12025/info

It is reported that Mesh Viewer is susceptible to a buffer overflow vulnerability. This issue is due to a failure of the application to properly bounds check user-supplied data prior to copying it into a fixed-size memory buffer.

This vulnerability allow remote attackers to alter the proper flow of execution of the application, potentially resulting in the execution of attacker-supplied machine code in the context of the application attempting to read malicious files. 

https://github.com/offensive-security/exploitdb-bin-sploits/raw/master/bin-sploits/25026.zip