Snipe Gallery 3.1.4 - 'image.php?image_id' SQL Injection

EDB-ID:

26800


Author:

r0t

Type:

webapps


Platform:

PHP

Date:

2005-12-13


Become a Certified Penetration Tester

Enroll in Advanced Web Attacks and Exploitation , the course required to become an Offensive Security Web Expert (OSWE)

GET CERTIFIED

source: https://www.securityfocus.com/bid/15844/info
 
Snipe Gallery is prone to multiple input-validation vulnerabilities. These issues are due to a failure in the application to properly sanitize user-supplied input.
 
Successful exploitation of these vulnerabilities could allow an attacker to compromise the application, access or modify data, steal cookie-based authentication credentials, and exploit vulnerabilities in the underlying database implementation. Other attacks are possible as well.
 
Snipe Gallery versions 3.1.4 and prior are vulnerable; other versions may also be affected. 

http://www.example.com/image.php?page=1&gallery_id=1&image_id=[SQL]