Snipe Gallery 3.1.4 - 'search.php?keyword' Cross-Site Scripting

EDB-ID:

26801

Author:

r0t

Type:

webapps

Platform:

PHP

Published:

2005-12-13

source: http://www.securityfocus.com/bid/15844/info
  
Snipe Gallery is prone to multiple input-validation vulnerabilities. These issues are due to a failure in the application to properly sanitize user-supplied input.
  
Successful exploitation of these vulnerabilities could allow an attacker to compromise the application, access or modify data, steal cookie-based authentication credentials, and exploit vulnerabilities in the underlying database implementation. Other attacks are possible as well.
  
Snipe Gallery versions 3.1.4 and prior are vulnerable; other versions may also be affected. 

http://www.example.com/search.php?keyword=%22%3E%3Cscript%3Ealert%28%
27r0t%27%29%3C%2Fscript%3E&search_cat=&search_type=and