MySQL 4.x/5.x - Server Date_Format Denial of Service

EDB-ID:

28234


Platform:

Linux

Published:

2006-07-18

source: https://www.securityfocus.com/bid/19032/info

MySQL is prone to a remote denial-of-service vulnerability because the database server fails to properly handle unexpected input.

This issue allows remote attackers to crash affected database servers, denying service to legitimate users. Attackers must be able to execute arbitrary SQL statements on affected servers, which requires valid credentials to connect to affected servers.

Attackers may exploit this issue in conjunction with latent SQL-injection vulnerabilities in other applications.

Versions prior to MySQL 4.1.18, 5.0.19, and 5.1.6 are vulnerable.

The following SQL statement will demonstrate this issue:

select date_format('%d%s', 1);