PHP-Nuke MyHeadlines 4.3.1 Module - Cross-Site Scripting

EDB-ID:

28487


Platform:

PHP

Published:

2006-09-04

source: http://www.securityfocus.com/bid/19825/info

PHP-Nuke MyHeadlines module is prone to a cross-site scripting vulnerability because the application fails to properly sanitize user-supplied input. 

An attacker may leverage this issue to have arbitrary script code execute in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

http://www.example.com/modules.php?op=modload&name=MyHeadlines&file=index&myh=user&myh_op=show_all[code]&eid=2474